Vliegende Pinguins Over vliegen, de pinguins en …

23Jun/091

ILO reset en dan….

Op werk hebben we HP proliant servers met ILO2 interfaces en nu ben ik een handleiding aan het prutsen hoe dat te configureren :)

Om van een standaard situatie uit te gaan had ik de ILO gereset, alleen ff vergeten dat dan het wachtwoord ook wordt gereset. Normaliter geen probleem, want dat staat op het label wat aan de server hangt... Right, label hing niet meer aan deze server :(

Dus... googlen naar een oplossing en dat bleek redelijk simpel te zijn.

Je moet twee RPMs installeren (er draait RHEL 5 op), namelijk hponcfg en hp-health (laatste versie pakken).

rpm -Uhv  hponcfg-1.9.0-3.noarch.rpm hp-health-8.2.6-5.rhel4.x86_64.rpm

Op de server draait RHEL 5, maar je kunt daar gewoon de RHEL4 pakketten op installeren, er zijn namelijk geen RHEL 5 pakketten.

Daarna een xml file maken met de volgende inhoud :

<RIBCL VERSION="2.0">
<LOGIN USER_LOGIN="Administrator" PASSWORD="boguswachtwoord">
  <USER_INFO MODE="write">
   <MOD_USER USER_LOGIN="Administrator">
    <PASSWORD value="nieuwwachtwoord"/>
   </MOD_USER>
  </USER_INFO>
</LOGIN>
</RIBCL>

Dan de hponcfg tool runnen met hponcfg -f filename.xml

En dan weer inloggen in de webinterface met 'Administrator' en 'nieuwwachtwoord'.

Klaar is Michel 😉

16Dec/071

Boem… alles uit !

Dat was wat men hoorde in Capelle aan den Ijssel, daar staat deze server in een datacentrum.

In de nacht van vrijdag 14 op zaterdag 15 december was men daar bezig de noodstroom voorziening te vervangen, hiervoor moesten alle machines uit. Op zich geen probleem, gecontroleerd down gaan van een server is meestal geen probleem. Nu ook niet, om 0:30 gingdie uit, om 2:30 weer aan. Echter ging om 4:30 de stroom er compleet af, er bleek bij de 7e test een accu ontploft te zijn. Nou, mijn drie harddisken ook !!!
3 van de 3 disken in een raid 5 array kapot is funest :( (2 van de drie trouwens ook)

Ik moest dus (gelukkig had ik disks in voorraad) op zaterdag avond erheen, disks vervangen en gelijk maar geheugen bijgeprikt (van 1Gb naar 2Gb). Server opnieuw geinstalleerd en stukje geconfigureerd. De rest vanaf thuis gedaan.

De volgende ochtend werkten de websites nog niet (klein rechtenprobleempje met MySQL) en de backup was niet niet helemaal teruggezet. Maar nu staat alles er weer op als het goed is.

Pfff... nu moet het wel blijven draaien, ik heb geen reserve disks meer !!

Huidige configuratie : dual PIII-933, 2Gb RAM, 3x36Gb Ultra SCSI-3 in RAID-5, CentOS 5.1 met Xen.

Hieronder de voorkant van de server :
voorkant server

En de achterkant :) :
achterkant server

   

Vliegende Pinguins is Stephen Fry proof thanks to caching by WP Super Cache